ITGlue has a Advised of a Performance Issue for North America Tenants
Incident Report for CyberQP
Resolved
ITGlue indicates that this should be fully resolved. Functionality with Quickpass should return to normal operations.
Posted May 12, 2023 - 08:36 PDT
Monitoring
A fix has been implemented and ITGlue is currently monitoring results. Users should be able to access the app again without errors.
Posted May 12, 2023 - 08:28 PDT
Investigating
ITGlue is investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app. We will provide further details here as soon as we can.

Region: North America
Applications: Web App, Mobile App, Chrome Extension
Posted May 12, 2023 - 08:02 PDT
This incident affected: Third Party Integrations (IT Glue API).