Agents Offline - Service running
Incident Report for CyberQP
Resolved
The vast majority of Agents have updated and we're seeing consistent results with connections.

If you are still having challenges with the Agent updates, please reach out to support@cyberqp.com .
Posted Apr 26, 2024 - 10:57 PDT
Update
Our team worked late into the night last night and has released Agent 4.1.3 as a resolution to the challenge seen yesterday.

The majority of Customer agents have updated overnight but if an agent is still stuck at a previous version, please update manually.

How to get the Agent Update
Auto Update: No action required. The agent checks for new updates every two hours.
Force Agent Update: Via RMM or other Management Tool force the Update Executable from this Path:
"C:\Program Files\Quickpass Software\Quickpass Server Agent\AgentUpdater.exe" - This will need to be ran with Administrative privileges.

Scripting/Direct Download Link: The agent download link is now updated and downloads via your script
Posted Apr 26, 2024 - 06:17 PDT
Monitoring
We are pleased to inform you that a Fixed Agent has been released as a Hotfix. Agent Version 4.1.1.1 has been released.

How to get the Agent Update
Auto Update: No action required. The agent checks for new updates every two hours.
Force Agent Update: Via RMM or other Management Tool force the Update Executable from this Path:
"C:\Program Files\Quickpass Software\Quickpass Server Agent\AgentUpdater.exe" - This will need to be ran with Administrative privileges.

Scripting/Direct Download Link: The agent download link is now updated and downloads via your script

Post-Update Verification:
After the update, there will be a period of time that the Agent still appears as offline. The Agent is designed to reconnect to the CyberQP infrastructure on a regular basis. As the queue of Agents that were on the previous version clears, the Agents will begin to appear as Online.


Should you experience any further challenges, please do not hesitate to reach out to support@cyberqp.com .Thank you for your patience while we worked on a resolution and we do apologize for any inconvenience this may have caused.

Regards,
CyberQP Support
Posted Apr 25, 2024 - 15:30 PDT
Identified
We have identified the issue and our team is currently working on a hotfix. We will send another update when the hotfix will be released today.
Posted Apr 25, 2024 - 10:36 PDT
Investigating
We are currently investigating an issue with Agents that have updated to 4.1.0.0 overnight. We're seeing behaviour where the Agent service is running on the system, however it is not communicating with the back end.
Symptoms include:
1. Agent Showing offline on the Dashboard
2. Service on Server is running.
3. Event Viewer -> Applications and Services Logs -> Quickpass Events -> Log entries indicating that the Service is attempting to connect to server "waiting for authentication" or repeated "Disconnect from Server" and then attempts to connect again.

As soon as we have an update from our internal teams we will update you with more information.
Posted Apr 25, 2024 - 07:22 PDT
This incident affected: EU (Agent) and US (Agent).